Lompat ke konten Lompat ke sidebar Lompat ke footer

Mengatasi Error Cannot use spatie/laravel-backup's latest version 8.4.0 as it requires ext-zip ^1 Laravel

Solusi Error Cannot use spatie/laravel-backup's latest version 8.4.0 as it requires ext-zip ^1.14.0 which is missing from your platform

Saat mencoba menginstal atau menggunakan package spatie/laravel-backup versi 8.4.0 atau lebih tinggi, Anda mungkin mengalami error berikut:

Cannot use spatie/laravel-backup's latest version 8.4.0 as it requires ext-zip ^1.14.0 which is missing from your platform.

Error ini terjadi karena package spatie/laravel-backup membutuhkan ekstensi PHP zip versi 1.14.0 atau lebih tinggi. Jika ekstensi ini tidak ada di sistem Anda, maka package spatie/laravel-backup tidak dapat diinstal atau digunakan.

Untuk mengatasi error ini, Anda perlu menginstal ekstensi PHP zip di sistem Anda. Caranya adalah dengan membuka file php.ini di folder C:\xampp\php\php.ini.

Cari baris berikut:

;extension=zip

Hapus tanda ; di awal baris tersebut sehingga menjadi:

extension=zip

Simpan file php.ini dan restart server web Anda. Setelah itu, Anda dapat mencoba menginstal atau menggunakan package spatie/laravel-backup kembali.

Berikut adalah langkah-langkah untuk mengatasi error ini secara lebih detail:

  1. Buka file php.ini di folder C:\xampp\php\php.ini.
  2. Cari baris berikut:
;extension=zip
  1. Hapus tanda ; di awal baris tersebut.
  2. Simpan file php.ini.
close