Lompat ke konten Lompat ke sidebar Lompat ke footer

error menggunakan composer require nao-pon/flysystem-google-drive:~1.1 pada laravel 9 & 10

Flysystem adalah library PHP yang menyediakan antarmuka abstrak untuk mengakses berbagai sistem penyimpanan, termasuk Google Drive. Salah satu adapter Flysystem Google Drive yang populer adalah nao-pon/flysystem-google-drive. Adapter ini sudah tidak diupdate selama 2 tahun, sehingga tidak disarankan untuk digunakan.

Jika Anda menggunakan adapter nao-pon/flysystem-google-drive, Anda dapat menggunakan alternatifnya, yaitu masbug/flysystem-google-drive-ext. Adapter ini masih aktif dikembangkan dan memiliki fitur-fitur yang lebih lengkap, seperti:

  • Dukungan untuk Google Drive API v4
  • Dukungan untuk virtual path
  • Dukungan untuk concurrent access

Untuk menggunakan adapter masbug/flysystem-google-drive-ext, Anda dapat menjalankan perintah berikut:

composer require masbug/flysystem-google-drive-ext
 

Kesimpulan

Adapter masbug/flysystem-google-drive-ext adalah alternatif yang lebih baik untuk adapter nao-pon/flysystem-google-drive. Adapter ini masih aktif dikembangkan dan memiliki fitur-fitur yang lebih lengkap.

 
close